This project has moved. For the latest updates, please go here.

Application gets stuck in startup

Feb 1, 2011 at 9:08 AM

Hi,

I just tried to use Vld. I included the windows.h and vld.h and builded my app. Unfortunately the application startup hangs up.

The last rows of output window looks like this:

'helloworld.exe': Loaded 'C:\WINNT\system32\comdlg32.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\comctl32.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\shell32.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\shlwapi.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\oleaut32.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\imm32.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\winspool.drv'
'helloworld.exe': Loaded 'C:\Program Files\Visual Leak Detector\bin\Win32\vld_x86.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\dbghelp.dll'
'helloworld.exe': Loaded 'C:\WINNT\system32\version.dll'
Debugger:: An unhandled non-continuable exception was thrown during process load
The program '[5740] helloworld.exe: Native' has exited with code -1073741511 (0xc0000139).

Am I missing some dll or something?

 

 

 

 

Sep 14, 2011 at 1:36 PM
Edited Sep 14, 2011 at 1:40 PM


My application also hangs on startup.
The only output i get though is "Visual Leak Detector Version 2.2 installed." and nothing else....
I'm using VS2005 and Qt 4.7.2.

Was really hoping to use VLD to track down memory leaks. :( 

Callstack:

>	ntdll.dll!_NtWaitForMultipleObjects@20()  + 0x15 bytes	
 	ntdll.dll!_NtWaitForMultipleObjects@20()  + 0x15 bytes	
 	ntdll.dll!_NtWaitForMultipleObjects@20()  + 0x15 bytes	
 	KernelBase.dll!_WaitForMultipleObjectsEx@20()  + 0x16b bytes	
 	kernel32.dll!_WaitForMultipleObjectsExImplementation@20()  + 0x8e bytes	
 	user32.dll!_RealMsgWaitForMultipleObjectsEx@20()  + 0xe2 bytes	
 	user32.dll!_MsgWaitForMultipleObjects@20()  + 0x1f bytes	
 	shell32.dll!_SHProcessMessagesUntilEventsEx@20()  + 0x43 bytes	
 	shell32.dll!_SHProcessMessagesUntilEvent@12()  + 0x29 bytes	
 	shell32.dll!CWaitTask::_Process()  + 0x107610 bytes	
 	shell32.dll!CWaitTask::s_WaitBeforeCursing()  + 0x12 bytes	
 	ntdll.dll!_RtlpTpWaitCallback@16()  + 0x79 bytes	
 	ntdll.dll!_TppWaitpExecuteCallback@8()  + 0x8d bytes	
 	ntdll.dll!_TppWorkerThread@4()  - 0x1185 bytes	
 	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
 	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
 	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes	

Jul 9, 2012 at 10:16 AM

I have the same problem. In the output it says 'Visual Leak Detector Version 2.2 installed.' but soon after that, after loading a few more DLLs, the application crashes with a First-chance exception (Access violation reading a location). Without vld.h everything fine. In my case vld.h is included in a project, that generates a DLL which is used by another application, if that matters.

Coordinator
Jul 9, 2012 at 11:19 PM

What OS you use?

Jul 10, 2012 at 7:53 AM

Sorry, forgot to mention that. In my case it's Windows 7 Professional x64 and Visual Studio 2008.

 

What's weird is: the first time I tried VLD, it crashed later than it does now, in a specific function, but I couldn't debug it (even though that function was from my own code). I couldn't even set a breakpoint. For some reason, VLD prevented propper debugging there. Then I made a complete rebuild, cleaning everything manually in the project to be sure, and now it simply crashes some time after the generated DLL of my project is loaded in the respective application.

Dec 3, 2013 at 1:42 AM
same problem here ... it works about 25% of the time :(
Jan 19, 2014 at 2:53 PM
I had exactly the same problem. In fact commenting the line #include <vld.h> in all the cpp files was fixing it.
I solved the problem by copying (NOT moving)
Visual Leak Detector\bin\dbghelp.dll
into the executable directory, which I forgot to do.
The wrong dll was being loaded,

Hope it helps.