This project has moved and is read-only. For the latest updates, please go here.

Does not work in Windows 8

Apr 16, 2012 at 9:16 PM

I've been using VLD for quite some time with various application in WinXP, Vista and Windows 7. 

But when I try using the same applications in Windows 8 (with the latest Consumer Preview [Beta] version), I get the following nondescript error: 

"The application was unable to start correctly (0xc0000142). Click OK to close the application".

If I do not link with VLD, it works correcly... I tried with various projects and always get the same result.

Apr 18, 2012 at 4:03 PM
Edited Apr 18, 2012 at 4:03 PM

I can't reproduce your issue. Works fine for me.

Apr 20, 2012 at 3:13 PM

It seems it doesn't produce the error with all types of DLL loaded in a project. I can produce the error with the library we're working on, but also with various OpenSource DLL I include in an "empty project" 

As an example, you get this problem when including ultraMaGE

At first glance, the error seems to be located when VLD updates its internal Module list...