This project has moved and is read-only. For the latest updates, please go here.

LINK: fatal error LINK1104: cannot open file "vld.lib"

Apr 25, 2013 at 8:05 PM
Hi, I am using vld to debug the memory leaking problems in a code written in VS C++6 under Win XP. I have followed vld instructions and can compile the program successfully, but received linker error LINK1104 that states vld.lib cannot be opened.

I have googled error and some people think the linker problem is due to use of MFC in a Static Library when having vld. I tried 1) no USE MFC and 2) Use MFC in a Shared DLL, but none works -- same problem (cannot open file "vld.lib”) when linking the code.

Does anyone have a clue?

Apr 25, 2013 at 9:05 PM
Jan 14, 2014 at 11:29 AM

i kind of have a similar issue. I have a cmake buildet toolkette under vc2008 windows xp. The projects base on a same framwork but work independently. Some of them can be builded with vld but the other not. Non of them use definitions in windows.h direktly.

Without any change in my code or vld.h i received errors from Microsoft_SDKs and told me there are ambiguous symbols. Since i cannot change the namespace i tried to include windows.h before vld.h. Then i received the Link error: cannot open file 'vld.lib'.

Maybe someone has any idea how can i fix it or how can the vld not denpendent on windows.h any more?

Thanks a lot!