VLD can't find pdb with relative path

I dont run my exe from the standard location in Visual Studio and have set a custom working directory vld seems to not find my PDB file even though its next to the exe. When I turn on DBGHELP_DBG...

Id #10626 | Release: None | Updated: Sat at 12:57 AM by NightCreature | Created: Sat at 12:55 AM by NightCreature

2017 support?

Obviously, this project is described as 2008-2015 support. But on the off chance that it would work, I tried compiling with VS 2017. Understandably, this didn't work. Is there a roadmap for 201...

Id #10625 | Release: None | Updated: Mar 16 at 3:18 PM by markfinal | Created: Mar 16 at 3:18 PM by markfinal

Application is crashing on start if VLD is used

Hi, I a new to VLD. I am working on Photoshop Plugin in which I want to detect the memory leaks. I installed the VLD 2.5.1 and included the vld.h file in main cpp file. I see that app crashes o...

Id #10624 | Release: None | Updated: Feb 14 at 6:26 AM by rudra123 | Created: Feb 14 at 6:26 AM by rudra123

waveOutOpen bug

Hi I found bug in VLD. If you use waveOutOpen function VLD will crash. I use waveOutOpen with following parameters: HWAVEOUT waveOut; WAVEFORMATEX waveFormat; DWORD idThread; ...

Id #10623 | Release: None | Updated: Jan 20 at 12:34 PM by Ankari | Created: Jan 20 at 12:34 PM by Ankari

The change of Microsoft.Cpp.x64.user.props by the installation breaks my build

I installed the VLD and found that the file Microsoft.Cpp.x64.user.props was completely changed. Previously it was like <?xml version="1.0" encoding="utf-8"?> <Project DefaultTargets="Build" To...

Id #10622 | Release: None | Updated: Jan 4 at 8:44 PM by addegofly | Created: Jan 4 at 8:44 PM by addegofly

Why is vld_x86.pdb requested?

I am deveoping an ActiveX control in VS2013 c++ to be used with MS Access. After starting the Debugging of the in Access embedded ocx, VS asks for the Position of the vld_x86.pdb file, which shall ...

Id #10621 | Release: None | Updated: Jan 3 at 5:43 PM by urtart1960 | Created: Jan 3 at 5:42 PM by urtart1960

Installing vld on windows 7 x86 fails

When installing vld on windows 7 x86, I get the following error : Internal Error: Cannot access 64-bit registry keys on this version of windows.

Id #10620 | Release: None | Updated: Dec 16, 2016 at 7:08 PM by thieum22 | Created: Dec 16, 2016 at 7:08 PM by thieum22

VLD fails with Visual Studio 2015

Hi, It appears the VLD is now broken. The software fails with 0xC0000005 when executing HMODULE const handle = LoadLibraryExW(name, nullptr, LOAD_LIBRARY_SEARCH_SYSTEM32); where name = api-ms-wi...

Id #10619 | Release: None | Updated: Jan 4 at 3:02 PM by benke_g | Created: Oct 6, 2016 at 1:43 AM by bibble235

Multiple Users on same machine

It seems that the installer will properly edit the C:\Users(UserName)\AppData\Local\Microsoft\MSBuild\v4.0\Microsoft.Cpp.x64.user.props file to add the %(AdditionalIncludeDirectories), etc... Howe...

Id #10618 | Release: None | Updated: Aug 31, 2016 at 11:07 PM by jimwheaton | Created: Aug 31, 2016 at 10:46 PM by jimwheaton

TestSuites fail

After compiling VLD 2.5 with Visual Studio 2015 i've ran all the tests to make sure it works. But all (or at least all memory-related tests) fail. The VLD always returns a memory leak of 0. Exam...

Id #10617 | Release: None | Updated: Aug 12, 2016 at 6:28 AM by roalter | Created: Aug 12, 2016 at 6:28 AM by roalter